Controller-based Automation

Global Drive Control (GDC)

L-force Controller as gateway
## Contents

1 About this documentation ............................................. 4  
  1.1 Conventions used .................................................. 5  
  1.2 Definition of notes used ......................................... 6  
2 Safety instructions ..................................................... 7  
3 The "Controller-based Automation" system ............................. 8  
4 Controller as gateway .................................................. 10  
  4.1 System overview .................................................... 10  
  4.2 Controller as gateway via CAN .................................... 11  
    4.2.1 Setting the communication path .............................. 11  
    4.2.2 Selecting the communication driver .......................... 11  
  4.3 Controller as gateway via EtherCAT ............................... 12  
    4.3.1 Setting the communication path .............................. 12  
    4.3.2 Selecting the communication driver .......................... 12  
5 Establishing an online connection .................................... 14  
  5.1 Connect to drive .................................................... 14  
  5.2 Remedy in the event of an error .................................. 15  
  5.3 Online mode via Controller gateway function ....................... 16  
6 Index ........................................................................ 17  

*Your opinion is important to us.* ........................................ 18
1 About this documentation

This documentation contains information on the parameter setting & configuration in the Lenze »Global Drive Control« (»GDC«).

Note!

This documentation supplements the mounting instructions and the associated hardware manuals supplied with the controllers supported.

The mounting instructions for the respective drive components contain safety instructions which must be observed!

Target group

This documentation addresses to all persons who want to parameterise, configure, and diagnose a controller by means of an L-force Controller and the »Global Drive Control« Engineering software.

Validity information

This manual is valid for the Lenze »Global Drive Control« from:
version 4.12 onwards

Document history

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>08/2008</td>
<td>TD11 First edition (control technology V2.1)</td>
</tr>
<tr>
<td>1.1</td>
<td>10/2010</td>
<td>TD11 Gateway function with EtherCAT supplemented (control technology V3.0)</td>
</tr>
</tbody>
</table>
1.1 Conventions used

This documentation uses the following conventions for the distinction between different types of information:

<table>
<thead>
<tr>
<th>Type of information</th>
<th>Writing</th>
<th>Examples/notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spelling of numbers</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Decimal separator</td>
<td>Point</td>
<td>The decimal point is always used. For example: 1234.56</td>
</tr>
<tr>
<td>Text</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Version information</td>
<td>Blue text colour</td>
<td>The information valid for or from one specific software version of the controller is marked accordingly in this documentation. Example: This function extension is available from software version V3.0!</td>
</tr>
<tr>
<td>Program name</td>
<td>&quot; « &quot;</td>
<td>The Lenze PC software »Global Drive Control«...</td>
</tr>
<tr>
<td>Window</td>
<td>Italics</td>
<td>The Message window... / The Options dialog box...</td>
</tr>
<tr>
<td>Variable identifier</td>
<td></td>
<td>By setting bEnable to TRUE...</td>
</tr>
<tr>
<td>Control element</td>
<td>Bold</td>
<td>The OK button... / The Copy command... / The Properties tab... / The Name input field...</td>
</tr>
<tr>
<td>Sequence of menu commands</td>
<td></td>
<td>If several commands must be used in sequence to carry out a function, the individual commands are separated by an arrow. Select File→Open to...</td>
</tr>
<tr>
<td>Shortcut</td>
<td>&lt;Bold&gt;</td>
<td>Press &lt;F1&gt; to open the online help. If a command requires a combination of keys, a &quot;+&quot; is placed between the key symbols: With &lt;Shift&gt;+&lt;ESC&gt; you can...</td>
</tr>
<tr>
<td>Program code</td>
<td>Courier</td>
<td>IF var1 &lt; var2 THEN a = a + 1 END IF</td>
</tr>
<tr>
<td>Keyword</td>
<td>Courier bold</td>
<td>Highlighted reference to another topic which is activated by means of a mouse-click in the online documentation.</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Underlined</td>
<td>Highlighted reference to another topic which is activated by means of a mouse-click in the online documentation.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Icons</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Page reference</td>
<td>(5)</td>
<td>Optically highlighted reference to another page. It is activated with a mouse-click in this online documentation.</td>
</tr>
<tr>
<td>Step-by-step instructions</td>
<td></td>
<td>Step-by-step instructions are indicated by a pictograph.</td>
</tr>
</tbody>
</table>
1.2 Definition of notes used

The following pictographs and signal words are used to indicate dangers and important information:

Safety instructions

Structure of safety instructions:

⚠️ Danger!

(characterises the type and severity of danger)

>Note

(describes the danger and provides information about how to prevent dangerous situations)

<table>
<thead>
<tr>
<th>Pictograph</th>
<th>Signal word</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🟢 Danger!</td>
<td>Danger of personal injury through dangerous electrical voltage  Reference to an imminent danger that may result in death or serious personal injury if the corresponding measures are not taken.</td>
<td></td>
</tr>
<tr>
<td>🟢 Danger!</td>
<td>Danger of personal injury through a general source of danger  Reference to an imminent danger that may result in death or serious personal injury if the corresponding measures are not taken.</td>
<td></td>
</tr>
<tr>
<td>🟥 Stop!</td>
<td>Danger of property damage  Reference to a possible danger that may result in property damage if the corresponding measures are not taken.</td>
<td></td>
</tr>
</tbody>
</table>

Application notes

<table>
<thead>
<tr>
<th>Pictograph</th>
<th>Signal word</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌟 Note!</td>
<td>Important note to ensure trouble-free operation</td>
<td></td>
</tr>
<tr>
<td>✪ Tip!</td>
<td>Useful tip for simple handling</td>
<td></td>
</tr>
<tr>
<td>☑️</td>
<td>Reference to other documents</td>
<td></td>
</tr>
</tbody>
</table>
2 Safety instructions

Please observe the following safety instructions when you want to commission a controller or system using the L-force controller.

⚠️ Read the documentation supplied with the system components thoroughly first before you start commissioning the devices and the L-force controller!
The system manual contains safety instructions which must be observed!

⚠️ Danger!
According to our present level of knowledge it is not possible to ensure the absolute freedom from errors of a software.

If necessary, systems with built-in controllers must be provided with additional monitoring and protective equipment in accordance with relevant safety regulations (e.g. law on technical equipment, regulations for the prevention of accidents), so that an impermissible operating status does not endanger persons or facilities.

During commissioning persons must keep a safe distance from the motor or the machine parts driven by the motor. Otherwise there would be a risk of injury by the moving machine parts.

⚠️ Stop!
If you change parameters in an engineering tool during there is an online connection to a device, the changes are directly accepted in the device!

A wrong parameter setting can cause unpredictable motor movements. By an unintended direction of rotation, too high speed, or jerky operation, the driven machine parts may be damaged!
3 The "Controller-based Automation" system

Centralised control technology increasingly finds its way into the field of automation technology. Due to their scaling options and various possibilities of combining visualisation and control in one device, Industrial PCs offer great advantages for many applications.

These L-force controllers are available with the following software equipment:

- L-force controller as component, on request with operating system, without additional software
- L-force controller as visualisation system (depending on the type, an additional panel may be required)
- L-force controller as control system

The "Controller-based Automation" system allows for the centralised control of Logic and Motion systems.

Note!

- When designing the system it is reasonable to operate the Logic and Motion devices on separate lines, respectively!
- If the EtherCAT bus system is used, no separate lines for Logic and Motion are required.

Further information on the parameter setting and configuration of the individual bus systems can be found in the following communication manuals:

- CANopen control technology - commissioning & configuration
- EtherCAT control technology - commissioning & configuration
- PROFIBUS control technology - commissioning & configuration
Lenze provides specifically well-matched system components:

- **L-force controller as control and visualisation system**
  - The L-force controller is the central component of the PC-based Automation system that uses the runtime software to control the Logic and Motion functionalities.
  - The L-force controller uses the fieldbus to communicate with the field devices.

- **Engineering tools for the Engineering PC**
  - The Engineering PC uses Ethernet to communicate with the L-force controller.
  - Use the various Engineering tools to configure and parameterise the system.

- **Fieldbuses**
- **Field devices**

⚠️ Read the Mounting Instructions supplied with the controller first before you start working!

The Mounting Instructions contain safety instructions which must be observed!
4 Controller as gateway

This chapter describes how to use the gateway function of a controller to establish an on-line connection to a field device.

4.1 System overview

With the »Global Drive Control« (»GDC«) you can access field devices like 9300, 8200, and ECS.

If the field devices are operated on an L-force Controller via the CAN/EtherCAT fieldbus, »GDC« provides the possibility of using the controller as gateway.

The »GDC« is connected to the L-force Controller via Ethernet.
4.2 Controller as gateway via CAN

4.2.1 Setting the communication path

Tip!

Before working on the communication parameters, switch to the offline mode. To activate the offline mode, press the F4 button:

To use the L-force Controller as gateway, you must select the suitable communication driver: Options → Communication.

4.2.2 Selecting the communication driver

Select Controller Gateway → CAN from the list of drivers available:

Access the Gateway → CAN dialog window via the Parameter button.

– Set communication parameters:

To set the communication parameters, you must enter the following configuration data:

<table>
<thead>
<tr>
<th>Information</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP address</td>
<td>IP address of the L-force Controller which serves as gateway for communication</td>
</tr>
</tbody>
</table>
4.3 Controller as gateway via EtherCAT

This chapter describes how to use the gateway function of a controller to establish an online connection to a field device via EtherCAT.

4.3.1 Setting the communication path

Tip!

Before working on the communication parameters, switch to the offline mode. To activate the offline mode, press the F4 button:

To use the L-force Controller as gateway, you must select the suitable communication driver: Options → Communication.

4.3.2 Selecting the communication driver

Select Controller Gateway → EtherCAT from the list of drivers available:

<table>
<thead>
<tr>
<th>Information</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAN interface</td>
<td>Number of the CAN interface to which the required field device is connected</td>
</tr>
<tr>
<td>CAN address</td>
<td>Node address of the field device which you want to trigger via the gateway function of the L-force Controller</td>
</tr>
</tbody>
</table>

► Confirm data by OK.
Access the Gateway -> EtherCAT dialog window via the Parameter button.
– Set communication parameters:

To set the communication parameters, you must enter the following configuration data:

<table>
<thead>
<tr>
<th>Information</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP address</td>
<td>IP address of the L-force Controller which serves as gateway for communica-</td>
</tr>
<tr>
<td>EtherCAT interface</td>
<td>Number of the EtherCAT interface to which the required field device is connected</td>
</tr>
<tr>
<td>EtherCAT Address</td>
<td>Node address of the field device which you want to trigger via the gateway function of the L-force Controller (fixed address addressing).</td>
</tr>
</tbody>
</table>

Confirm data by OK.
5 Establishing an online connection

5.1 Connect to drive

**Note!**
In order to be able to establish an online connection to a controller with the gateway function via EtherCAT, the EtherCAT master has to be in the PREOP (Pre-operational) or OP (Operational) state.

**Tip!**
Exit the offline mode by pressing the F4 button if the F2 button is deactivated.

**Note!**
A manual assignment of the device description via the F3 button is not required.

Click F2 to call the Connect to drive dialog window:

Activate the search process by pressing the Connect button to establish an online connection to the drive.
The parameters of the connected drive are read from the connected drive.

5.2 Remedy in the event of an error

If no drive can be found, the »GDC« displays an error message:

Proceed as follows to eliminate the error:
- Check the physical connections to the drive controller and the L-force Controller,
- Make sure that the communication parameters set for the physical configuration are correct.
- Make sure that the device description file for the corresponding device is installed.

Information on the respective target system of the »GDC« can be found in the corresponding hardware manual.
5.3 Online mode via Controller gateway function

- After the parameters have been read in successfully, the drive is in the online mode. The drive parameters are available in the »GDC«:

![GDC interface](image)

In a separate window, the »GDC« provides an overview of the selected drives at the system bus:

![Drives connected to bus](image)

**Note!**

The »GDC« displays the selected drive in the *Drives connected to bus* dialog window via the gateway function. More drives can be connected to the system bus, which are not visible in the overview of the dialog window.
6 Index

A
Application notes 6

D
Document history 4

E
E-mail to Lenze 18

F
Feedback to Lenze 18

L
Layout of the safety information 6

S
Safety 7
Safety instructions 6
Setting the communication path 11
Structure of safety instructions 6

T
Target group 4
Your opinion is important to us

These instructions were created to the best of our knowledge and belief to give you the best possible support for handling our product.

If you have suggestions for improvement, please e-mail us to:
feedback-docu@Lenze.de

Thank you for your support.

Your Lenze documentation team